Overview 26 matches · 0 in Waratek scope · 0 protected · 3 exploited · 1 CISA KEV · 7 EPSS ≥ 0.5
Protected by Waratek
0
0.0%
Rule in development
0
0.0%
Mitigation candidate
0
0.0%
No exploit published
0
0.0%
Outside Waratek scope
1
3.8%
Not applicable
25
96.2%
Withdrawn CVE
0
0.0%
blocked by ARMR today
0
0.0%
partly blocked
0
0.0%
not blocked
26
100.0%
not established
0
0.0%
unrecorded
0
0.0%
Exploited
3
11.5%
Working exploit published
20
76.9%
Proof of concept only
3
11.5%
Forecast only
0
0.0%
No public exploit
0
0.0%
split by
peak 3 / year
19982
Not applicable2
High1
Low1
not blocked2
Working exploit published2
19992
Not applicable2
High1
Medium1
not blocked2
Working exploit published2
20003
Not applicable3
High1
Medium1
Low1
not blocked3
Working exploit published3
20012
Not applicable2
High1
Medium1
not blocked2
Working exploit published2
20023
Not applicable3
High2
Medium1
not blocked3
Working exploit published3
20030
20040
20050
20060
20072
Not applicable2
Medium2
not blocked2
Working exploit published2
20081
Not applicable1
Medium1
not blocked1
Working exploit published1
20092
Not applicable2
High1
Medium1
not blocked2
Exploited1
Working exploit published1
20101
Not applicable1
Medium1
not blocked1
Working exploit published1
20110
20121
Not applicable1
Medium1
not blocked1
Working exploit published1
20130
20140
20151
Not applicable1
High1
not blocked1
Exploited1
20161
Not applicable1
High1
not blocked1
Exploited1
20170
20180
20192
Not applicable2
High2
not blocked2
Working exploit published1
Proof of concept only1
20201
Not applicable1
High1
not blocked1
Working exploit published1
20210
20220
20230
20242
Outside Waratek scope1
Not applicable1
High2
not blocked2
Proof of concept only2
200020032006200920122015201820212024
| CVE | Severity | Published▾ | Status | Exploitation | Description |
|---|---|---|---|---|---|
| CVE-2023-50868 | High | 2024-02-14 | Outside Waratek scope | Proof of concept only | The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations. |
| CVE-2023-50387 | High | 2024-02-14 | Not applicable | Proof of concept only | Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records. |
| CVE-2020-8617 | High | 2020-05-19 | Not applicable | Working exploit published | Using a specially-crafted message, an attacker may potentially cause a BIND server to reach an inconsistent state if the attacker knows (or successfully guesses) the name of a TSIG key used by the server. Since BIND, by default, configures a local session key even on servers whose configuration does not otherwise make use of it, almost all current BIND servers are vulnerable. In releases of BIND dating from March 2018 and after, an assertion check in tsig.c detects this inconsistent state and deliberately exits. Prior to the introduction of the check the server would continue operating in an inconsistent state, with potentially harmful results. |
| CVE-2019-6467 | High | 2019-10-09 | Not applicable | Proof of concept only | A programming error in the nxdomain-redirect feature can cause an assertion failure in query.c if the alternate namespace used by nxdomain-redirect is a descendant of a zone that is served locally. The most likely scenario where this might occur is if the server, in addition to performing NXDOMAIN redirection for recursive clients, is also serving a local copy of the root zone or using mirroring to provide the root zone, although other configurations are also possible. Versions affected: BIND 9.12.0-> 9.12.4, 9.14.0. Also affects all releases in the 9.13 development branch. |
| CVE-2017-3141 | High | 2019-01-16 | Not applicable | Working exploit published | The BIND installer on Windows uses an unquoted service path which can enable a local user to achieve privilege escalation if the host file system permissions allow this. Affects BIND 9.2.6-P2->9.2.9, 9.3.2-P1->9.3.6, 9.4.0->9.8.8, 9.9.0->9.9.10, 9.10.0->9.10.5, 9.11.0->9.11.1, 9.9.3-S1->9.9.10-S1, 9.10.5-S1. |
| CVE-2016-2776 | High | 2016-09-28 | Not applicable | Exploited | buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x before 9.11.0rc3 does not properly construct responses, which allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted query. |
| CVE-2015-5477 | High | 2015-07-29 | Not applicable | Exploited | named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via TKEY queries. |
| CVE-2012-3571 | Medium | 2012-07-25 | Not applicable | Working exploit published | ISC DHCP 4.1.2 through 4.2.4 and 4.1-ESV before 4.1-ESV-R6 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a malformed client identifier. |
| CVE-2010-2156 | Medium | 2010-06-07 | Not applicable | Working exploit published | ISC DHCP 4.1 before 4.1.1-P1 and 4.0 before 4.0.2-P1 allows remote attackers to cause a denial of service (server exit) via a zero-length client ID. |
| CVE-2009-0696 | Medium | 2009-07-29 | Not applicable | Exploited | The dns_db_findrdataset function in db.c in named in ISC BIND 9.4 before 9.4.3-P3, 9.5 before 9.5.1-P3, and 9.6 before 9.6.1-P1, when configured as a master server, allows remote attackers to cause a denial of service (assertion failure and daemon exit) via an ANY record in the prerequisite section of a crafted dynamic update message. |
| CVE-2009-0692 | High | 2009-07-14 | Not applicable | Working exploit published | Stack-based buffer overflow in the script_write_params method in client/dhclient.c in ISC DHCP dhclient 4.1 before 4.1.0p1, 4.0 before 4.0.1p1, 3.1 before 3.1.2p1, 3.0, and 2.0 allows remote DHCP servers to execute arbitrary code via a crafted subnet-mask option. |
| CVE-2008-1447 | Medium | 2008-07-08 | Not applicable | Working exploit published | The DNS protocol, as implemented in (1) BIND 8 and 9 before 9.5.0-P1, 9.4.2-P1, and 9.3.5-P1; (2) Microsoft DNS in Windows 2000 SP4, XP SP2 and SP3, and Server 2003 SP1 and SP2; and other implementations allow remote attackers to spoof DNS traffic via a birthday attack that uses in-bailiwick referrals to conduct cache poisoning against recursive resolvers, related to insufficient randomness of DNS transaction IDs and source ports, aka "DNS Insufficient Socket Entropy Vulnerability" or "the Kaminsky bug." |
| CVE-2007-2930 | Medium | 2007-09-12 | Not applicable | Working exploit published | The (1) NSID_SHUFFLE_ONLY and (2) NSID_USE_POOL PRNG algorithms in ISC BIND 8 before 8.4.7-P1 generate predictable DNS query identifiers when sending outgoing queries such as NOTIFY messages when answering questions as a resolver, which allows remote attackers to poison DNS caches via unknown vectors. NOTE: this issue is different from CVE-2007-2926. |
| CVE-2007-2926 | Medium | 2007-07-24 | Not applicable | Working exploit published | ISC BIND 9 through 9.5.0a5 uses a weak random number generator during generation of DNS query ids when answering resolver questions or sending NOTIFY messages to slave name servers, which makes it easier for remote attackers to guess the next query id and perform DNS cache poisoning. |
| CVE-2002-1220 | Medium | 2002-11-29 | Not applicable | Working exploit published | BIND 8.3.x through 8.3.3 allows remote attackers to cause a denial of service (termination due to assertion failure) via a request for a subdomain that does not exist, with an OPT resource record with a large UDP payload size. |
| CVE-2002-0525 | High | 2002-08-12 | Not applicable | Working exploit published | Format string vulnerabilities in (1) inews or (2) rnews for INN 2.2.3 and earlier allow local users and remote malicious NNTP servers to gain privileges via format string specifiers in NTTP responses. |
| CVE-2002-0702 | High | 2002-07-26 | Not applicable | Working exploit published | Format string vulnerabilities in the logging routines for dynamic DNS code (print.c) of ISC DHCP daemon (DHCPD) 3 to 3.0.1rc8, with the NSUPDATE option enabled, allow remote malicious DNS servers to execute arbitrary code via format strings in a DNS server response. |
| CVE-2001-1442 | Medium | 2001-04-21 | Not applicable | Working exploit published | Buffer overflow in innfeed for ISC InterNetNews (INN) before 2.3.0 allows local users in the "news" group to gain privileges via a long -c command line argument. |
| CVE-2001-0010 | High | 2001-02-12 | Not applicable | Working exploit published | Buffer overflow in transaction signature (TSIG) handling code in BIND 8 allows remote attackers to gain root privileges. |
| CVE-2000-0887 | Medium | 2000-12-19 | Not applicable | Working exploit published | named in BIND 8.2 through 8.2.2-P6 allows remote attackers to cause a denial of service by making a compressed zone transfer (ZXFR) request and performing a name service query on an authoritative record that is not cached, aka the "zxfr bug." |
| CVE-2000-1029 | High | 2000-12-11 | Not applicable | Working exploit published | Buffer overflow in host command allows a remote attacker to execute arbitrary commands via a long response to an AXFR query. |
| CVE-2000-0472 | Low | 2000-02-06 | Not applicable | Working exploit published | Buffer overflow in innd 2.2.2 allows remote attackers to execute arbitrary commands via a cancel request containing a long message ID. |
| CVE-1999-0848 | Medium | 1999-11-10 | Not applicable | Working exploit published | Denial of service in BIND named via consuming more than "fdmax" file descriptors. |
| CVE-1999-0705 | High | 1999-09-01 | Not applicable | Working exploit published | Buffer overflow in INN inews program. |
| CVE-1999-1499 | Low | 1998-04-10 | Not applicable | Working exploit published | named in ISC BIND 4.9 and 8.1 allows local users to destroy files via a symlink attack on (1) named_dump.db when root kills the process with a SIGINT, or (2) named.stats when SIGIOT is used. |
| CVE-1999-0009 | High | 1998-04-08 | Not applicable | Working exploit published | Inverse query buffer overflow in BIND 4.9 and BIND 8 Releases. |